Downloads

FireflyPro is currently compatible with Windows and Mac OS X machines.
To Install the software, please select the relevant download below and follow
the installation steps on the following screen.

Windows
Requires Windows 7, 8, or 10
Current version – 1.81
OS X
Requires Mac OS X 10.8 or later
Video playback requires QuickTime 7.0 or later
Current version – FireflyPro Version 1.7.16

Note: For users running a Mac OS X older than
10.8, please contact: support@fireflyglobal.com

Windows
Requires Windows 7, 8, or 10
Current version – 1.75
Windows
Requires Windows 7, 8, or 10
Current version – 1.73